Images and broken wall
  • Hello,
    Firstly thanks for the great theme, I'm glad to one of the first to use it in anger!
    Anyway, I am having some problems getting the wall to display, as mentioned in the other support post, if I select all categories the wall just doesn't display, however, if I select only one category the wall grid shows but the images don't load.
    I have just imported my posts from my current site so I guess they will need a little tweaking, bu the featured images are not displaying in the posts. Maybe you could dial in and have a look at these issue.
    Many thanks.
  • Hi,

    Apologies, you will need the website address http://blog.karbalion.com/

    Also spotted this in the console

    "A TimThumb error has occured

    The following error(s) occured:
    Could not create the index.html file - to fix this create an empty file named index.html file in the cache directory.
    Could not find the internal image you specified.
    Query String : src=http://blog.karbalion.com/files/2012/07/Mark-Zuckerberg-e1350374520575.jpg&w=860&zc=1&q=90&a=c
    TimThumb version : 2.8.10"

    Cheers.
  • Hi,

    This is a file permissions issue. The timthumb is not able to generate thumbnails inside the Wall/scripts/cache folder. It is happening because the web server i.e., the Apache user is not having write access to the folder. This is a common issue with dedicated and virtual dedicated servers. The solution here is to provide write access to the Apache user and the most optimum way to do is to provide write access for the cache folder to the group, because Apache will definitely be a member of the file group.

    If you find this confusing, you can provide me temporary ftp access and I will fix the permissions. Please send any confidential info via PM.

    Regards
    Chang
  • Hi Chang,
    I've given the cache folder 777 mod, which has cured the index error, but i'm still getting the file not found. I'm using a bitnami multisite instance hosted on an aws cloud pc. I'm thinking it's a multisite issue, what do you think?
    Reuben
  • Hi Reuben,

    777 is a dangerous mode.

    Whether it is a multisite issue or not depends upon the method of implementation of virtuality.

    One way we can try to diagnose this issue is to debug the timthumb.php during runtime at your hosting. That will require me access to the scripts folder in the ftp atleast.

    Regards
    Chang

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!